Usando o Java 8 no site da Caixa Econômica Federal

1 Flares Twitter Facebook LinkedIn Google+ 1 Pin It Share Filament.io 1 Flares ×

A dica definitiva para quem precisa usar o internet banking com o Java 8 na CEF via Linux.

Então vamos mostrar como usar o site da Caixa Econômica Federal e o Java 8 da Oracle (Ubuntu/Linux Mint). Usaremos o navegador Firefox como padrão.

Java 8

Instalando o Java 8

Abra o terminal e digite os comandos abaixo:

APRENDA A DOMINAR O LINUX

Aprenda a dominar o LINUX de uma vez por todos, pegue sua cópia

  • Ferramentas para instalar softwares adicionais
  • Shell do LINUX passo a passo, e muito mais...
$ sudo apt-get purge openjdk*
$ sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer
$ sudo apt-get install oracle-java8-set-default

Fonte: http://www.vivaolinux.com.br/dica/Java-8-Oracle-no-Ubuntu-e-Linux-Mint

Após a instalação é necessário instalar a cadeia de certificados da CEF.

Acesse o site da CEF: http://www.certificado.caixa.gov.br ou aqui.

No lado direito da página, entre no link – Instalação e Arquivos – Vá até a segunda opção com o título: Certificados emitidos na cadeia V2 da AC CAIXA (são 5 certificados).

Assunto indicado:  Como converter formatos de arquivos via terminal

Clique em salvar em cada um deles. Ao clicar em salvar ele pedirá pra selecionar o tipo de certificado, setar a primeira e a terceira opção.

Feche o navegador e abra-o novamente. Entre no site da CEF. Logue o seu usuário.

Aparecerá o cadastro de computador (clicar em PERMITIR QUE APARECER NOS BOTÕES).

Após novo cadastro do computador, entre na sua conta.

OBS:
Diferente do que as pessoas acreditam, a instalação dos certificados da CEF foram obtidos com ajuda do 0800 da CEF, ou seja, deram suporte ao Linux. Este procedimento foi feito em um escritório Jurídico que adotou o Linux (LINUX MINT) como sistema operacional

Dica enviada pelo leitor Douglas Giovani Oechsler

É isso ai, amigos. Agora poderemos acessar o site da Caixa e assim não termos mais problemas com o Java 8.

Related Posts Plugin for WordPress, Blogger...
1 Flares Twitter Facebook LinkedIn Google+ 1 Pin It Share Filament.io 1 Flares ×

Comentários

  1. Olá Maudy.
    Fiquei extremamente feliz com esse post, porque já tinha tentado de tudo, sem sucesso.

    Bem, executei o procedimento como descrito no post. Mas mesmo assim ainda não consigo acesso minha conta no site da CEF.
    Acontece que quando o Java me pergunta se quero executa-lo para esse site, e eu digo que sim, ele me mostra esta mensagem:
    “Falha na execução da biblioteca nativa ou ambiente não suportado”.
    E não vai para frente, voltando para a tela de login da CEF.

    Alguém sabe me dizer o que está acontecendo, e/ou o que posso fazer para que isso seja resolvido?

    Abraço.

    • No meu também aparece essa mensagem, mas consigo acessar normalmente. No Firefox, tente ir em complementos, plugins e ative o java plugin. Qualquer coisa, limpe os cookies tb.
      Outra coisa: funcionou também para acesso ao Banco do Brasil.

  2. Até que enfim. Suas dicas anteriores não haviam funcionado, mas essa deu certo de primeira. Obrigado por compartilhar.

  3. Teste e e funcionou no Ubuntu 14.04 com Firefox 29.
    Apenas uma observação, na primeira vez só funcionou depois que marquei “Desejo acessar a versão anterior do Internet Banking CAIXA” na hora de logar como Pessoa Física. Sem marcar isso dava erro: “Falha na execução da biblioteca nativa ou ambiente não suportado”.
    Mas depois consegui logar sem marcar a “…versão anterior…”.

  4. Maravilha ! Fazia um tempo que nao vinha para este site , mas voltei na hora certa ! Agora com esta “dica” salvadora consigo pagar minhas contas no itau novamente usando o Chrome no MintKDE 16 :-)
    Obrigado por compartir !!

  5. Fiz todo o procedimento, e depois de digitar meu usuário, a tela seguinte me pede isso:

    “Instalação do Módulo Adicional de Segurança CAIXA
    Senhor(a) cliente,
    Identificamos que esse computador não possui o seguinte critério de segurança”

    Sendo que esse tal módulo é para windows, pois é um arquivo .exe

    O que eu faço?

  6. Não entendi essa parte aqui;

    Clique em salvar em cada um deles. Ao clicar em salvar ele pedirá pra selecionar o tipo de certificado, setar a primeira e a terceira opção.

    Quando clico nos certificados ele fazem o download e mais nada.

    Como proceder nessa instalação?

  7. João Cavalcante diz:

    Olá amigo Maudy,
    Estou querendo acessar minha conta na caixa, já fiz de tudo que nos outros foruns estavam postados. Eu estava com a versão do Java 1.7.0_55, então resolvi instalar a versão 8 Java conforme sua dica. Fiz tudo direitinho, instalei os 5 certificados. Para surpresa minha continua o mesmo erro ! Quando vou entrar na minha, dá o seguinte novamente:
    “Foi detectado um problema no cadastramento de máquina. Clique aqui para efetuar a instalação do JAVA, requisito para o correto cadastramento da máquina.”
    Já não sei o que fazer. Por favor me ajude(m) a resolver esse problema.
    Dados do meu sistema: Ubuntu 14.04 LTS de 32 bits.
    Ok. Obrigado !!!!

  8. João Cavalcante diz:

    Ah, sim detalhe importante:
    O Java 8 foi instalado com sucesso.

  9. Semi alternativa editada ( fonte: http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html)
    $ sudo su
    $ apt-get autoremove –purge openjdk-7-jre icedtea-7-plugin
    $ echo “deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main” | tee /etc/apt/sources.list.d/webupd8team-java.list
    echo “deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main” | tee -a /etc/apt/sources.list.d/webupd8team-java.list
    apt-key adv –keyserver keyserver.ubuntu.com –recv-keys EEA14886
    apt-get update
    $ apt-get install oracle-java8-installer
    $ sudo apt-get install oracle-java8-set-default
    E então a cadeia de certificados.

  10. Felipe Braga diz:

    Só faltou isso (de http://www.vivaolinux.com.br/dica/Internet-Banking-Caixa-no-Ubuntu-1310-Solucao-de-acesso-com-Firefox-e-Java-8):

    1. no “Oracle Java 8 Plugin Control Panel”

    Vá na até a aba “Segurança”, entre em “Gerenciar Exceções” ou “Editar Lista de Sites”. Adicione, um a um, os seguintes endereços:

    https://internetbanking.caixa.gov.br/siwinstatic/applet/gbas/gbas.jar
    https://internetbanking.caixa.gov.br
    https://internetbanking.caixa.gov.br/SIIBC/index.processa
    https://internetbankingpf.caixa.gov.br/SIIBC/siwinCtrl

    • Vinicius Mundim Zucheratto e Figueiredo diz:

      Prezados, boa noite.

      Realizei as operações aqui orientadas, inclusiva a do comentário do Felipe Braga. E até agora não consegui exito. Ao preencher a primeira tela de cadastro para usuário no site da caixa aparece a seguinte mensagem:


      Senhor(a) cliente,
      Identificamos que esse computador não possui o seguinte critério de segurança.
      Módulo Adicional de Segurança CAIXA
      Após finalizar a instalação você terá mais proteção nas suas transações ao utilizar o Internet Banking CAIXA.”

      Há um botão de Voltar / Concordo. Clico em Concordo e nada acontece no Firefox.
      No Chromium, o site orienta a instalação da extensão “GBBD Caixa Economica Federal”, mas também sem sucesso.

      Alguém tem alguma ideia do que posso fazer?

      Ubuntu 14.04
      Firefox 35.0.1
      Chromium 39.0.2171.65 Ubuntu 14.04 (64-bit)

      Obrigado

      • Cara acho que você, pela descrição acima utiliza micro de 64 bits então precisa converter as dicas para o padrão de sua máquina. Vá na sacolinha ou no synaptic (o que eu acho melhor pois é mais visível) e busque os mesmos programas só que para 64 bits, você pode também instalar diretamente do site da oracle java. Boa sorte.

  11. Willians da Silva diz:

    OBRIGADO.

    Há muito tempo busco uma alternativa para acessar a minha conta da CEF. Eu estava usando maquina virtual com xp instalada só para ver minha conta.

    funcionou perfeitamente, muito obrigado.

  12. Geniel Borges diz:

    Eu já estava para desistir do Linux quando achei seu artigo, que resolveu meu problema na primeira tentativa. Tenho outro problema que não me faz desistir do linux, mas quero achar a solução também, quem sabe você já tenha a solução.
    Jogos do facebook solicitam flash player, fiz todas instruções que achei mas, como no site da caixa não resolveu antes de seguir suas instruções,
    Você pode fazer mais essa gentileza?

  13. nao consigo achar os certificados , o link nao funciona de download

  14. Meu problema: quando acesso o site de certificados da caixa recebo:
    You are not authorized to view this page
    You do not have permission to view this directory or page using the credentials that you supplied.

    Please try the following:

    Contact the Web site administrator if you believe you should be able to view this directory or page.
    Click the Refresh button to try again with different credentials.

    HTTP Error 401.1 – Unauthorized: Access is denied due to invalid credentials.
    Internet Information Services (IIS)

    Technical Information (for support personnel)

    Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
    Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Authentication, Access Control, and About Custom Error Messages.

  15. Muito grato. Salvou meu dia. Valeu.

  16. Prezado o problema com a caixa voltou . Agora o suporte alega que com Ubuntu 64bits não é possível acessar o internet banking. Tem algum macete novo para adequarmos a esta situação nova.Ou é melhor mudar de banco.

  17. Prezado os links dos certificados não existem mais. O suporte da caixa diz que não é possível acessar mais com ubuntu 64bits.

    • Ricardo, só ubuntu 64bits (o que uso), ou qualquer distro linux? É impressionante a incompetência desse pessoal! E, como tudo neste governo, apoio ao software livre só na propaganda.

      • Júlio Sousa Mota Filho diz:

        Liguei na Caixa economica e o suporte informou que o internet bank não funciona no sistema Linux 64 bits.
        Utilizo o Debian Jessie 64bits

  18. Marcelo Teodoro diz:

    Muito bacana a dica! Conseguir instalar o Java 8, porém a cadeia de certificado, não foi possível… Faltou informar qual versão do Linux Mint foi usado, provavelmente a 32 bits. Em contato com essa porcaria de banco chamado caixa, que tem um suporte de ultimo mundo, informou que pra ter acesso ao internet banking é necessário que o sistema (Linux) seja 32 bits ( Ridículo)

Deixe o seu comentário

*

1 Flares Twitter 0 Facebook 0 LinkedIn 0 Google+ 1 Pin It Share 0 Filament.io 1 Flares ×